The performance issues have been resolved. The root cause was a resource configuration issue in our application cluster that limited its ability to scale effectively under load. We've adjusted resource allocation and autoscaling settings to improve responsiveness and prevent recurrence. All services are operating normally.
Posted Jul 01, 2026 - 11:37 CDT
Monitoring
We are currently experiencing degraded performance. Some users may notice slower response times or delays in data updates. Our team has identified the issue and is actively working to clear the backlog and restore normal performance. We will provide updates as the situation progresses.
Posted Jul 01, 2026 - 10:49 CDT
This incident affected: Mobile Services, Dashboard Portal, Integration Services and Gateway, and Vital Sign Integration.