Client application connectivity has been restored, and all services are now fully operational. We will continue to monitor and open a new incident if further issues arise. Thank you for your patience.
The Graphium Health Team
Posted Nov 12, 2025 - 10:49 CST
Monitoring
Client application connectivity is returning to normal as we see the latency issues resolve. All indications are that this incident was caused by an as-yet-unreported issue at AWS. Our team continues to monitor.
Posted Nov 12, 2025 - 10:27 CST
Update
Latency has diminished, but we are still investigating the cause.
Posted Nov 12, 2025 - 10:10 CST
Investigating
We are currently experiencing increased network latency affecting our client applications. Our engineers are actively investigating.
Posted Nov 12, 2025 - 09:46 CST
This incident affected: Mobile Services, Dashboard Portal, Integration Services and Gateway, and Vital Sign Integration.